GTKC Knowledgebase
A little bit of wisdom
Cisco VA887 router configuration for PPPoE
Posted by  Admin on


UPDATED: I noticed there were a few errors in the config I posted previously.

This configuration should work with most UK ISPs - I use Unchained ISP and it works well with them.

See my other posts to use the VA887 as a modem instead of a router, and use Linux as a PPPoE provider.

Note that the config will require some adjustment to suit your own ISP and does require a static IP address.

!
version 15.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Broadband-Router
!
boot-start-marker
boot system flash c880data-universalk9-mz.153-3.M.bin
boot-end-marker
!
!
no logging console
enable secret [your_secret]
!
aaa new-model
!
!
!
!
!
!
!
aaa session-id common
memory-size iomem 10
clock timezone London 0 0
clock summer-time BST recurring last Sun Mar 2:00 last Sun Oct 2:00
!
!
!
!
!
!
!
!
ip domain name example.com
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip cef
no ipv6 cef
!
!
license udi pid CISCO887VA-K9 sn FCZ153394TL
license boot module c880-data level advsecurity
!
!
username [username] privilege 15 secret [user-password]
!
!
!
!
!
controller VDSL 0
 firmware filename flash:VA_A_39d_B_38h3_24h_1.bin
!
ip ssh authentication-retries 2
ip ssh version 2
!
!
!
!
!
!
!
!
!
interface Ethernet0
 no ip address
 no shutdown
!
interface Ethernet0.101
 description Tagging for PPPoE (VDSL 0)
 encapsulation dot1Q 101
 no ip redirects
 no ip proxy-arp
 ip virtual-reassembly in
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface FastEthernet0
 description Downlink_to_firewall
 no ip address
 no shutdown
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface Vlan1
 ip address [your_ip_address] [your_netmask]
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
!
interface Dialer0
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname user@bt.com
 ppp chap password 0 password
 ppp ipcp dns request
 ppp ipcp route default
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip access-list standard SSH_ACCESS
 permit [your_ip] [your_netmask]
!
!
!
!
!
!
line con 0
 logging synchronous
 no modem enable
line aux 0
line vty 0 4
 access-class SSH_ACCESS in
 logging synchronous
 transport input ssh
!
ntp server 0.uk.pool.ntp.org
ntp server 1.uk.pool.ntp.org prefer
!
end


Tags: Networking , Cisco

Return to home page: Home